Xoops Cube Lagacy 2.2 alpha3が出ていたのでちょい試してみました。

しかーし・・・

管理画面のスタイルシートが正常に読み込まれてないみたいです。

互換レンダーシステムの所の言語ファイルが見つからないといわれる。

言語ファイルmodules/legacyRender/language/ja_utf8/modinfo.phpに、

define('_MI_LEGACYRENDER_ADMENU_HTACCESS_VIEW', "htaccess 設定");

を加える、次に、htaccess設定(_MI_LEGACYRENDER_ADMENU_HTACCESS_VIEW)にアクセスすると

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in **/modules/legacyRender/language/ja_utf8/admin.php on line 102

のエラーが発生、で、該当部分(明らかに構文エラーです)の

define('_AD_LEGACYRENDER_DESC_HTACCESS', "お使いのサーバが mod_rewrite に対応していれば、このページの設定を .htaccess ファイルに追加することで URI を変換することが出来ます。このオプションを使う場合、<a href="'.XOOPS_URL.'/modules/legacy/admin/index.php?action=PreferenceEdit&confcat_id=1">全般設定</a> 画面で Cool Uri のオプションを「はい」に設定してください。");

define('_AD_LEGACYRENDER_DESC_HTACCESS', 'お使いのサーバが mod_rewrite に対応していれば、このページの設定を .htaccess ファイルに追加することで URI を変換することが出来ます。このオプションを使う場合、<a href="'.XOOPS_URL.'/modules/legacy/admin/index.php?action=PreferenceEdit&confcat_id=1">全般設定</a> 画面で Cool Uri のオプションを「はい」に設定してください。');

に変更(ダブルクオートをシングルクオートに)
これでやっと正常に表示されるようになりました。

ちなみに、親父はUTF-8でインストールしましたが、EUC-JPでも同様みたいです。 英語の方は言語ファイルが正常に作られており正常です。

しかし、言語ファイル側の不具合でスタイルシートが読み込まれないって、ちょっと危なっかしい気がするんですが…

XCL日本チームの方々、忙しいのかなぁ、あまり目を通さずに、リリースされてるような(まぁAlpha版なので、そのぐらいは自分で直せってことなのかな)

3 コメント

  1. お試しいただきありがとうございます ^^
    お手間をかけさせてしまい申し訳ないです。
    開発中は英語の言語でやっているので、日本語でのチェックが疎かになっていたのはご指摘の通りです m(__)m

  2. 親父殿、ごぶさたしております。

    ひそかに復活されていたのですね。まずはおめでとうございます。
    Joomlaは自分は試してみて挫折しました。いつもながらチャレンジ精神に敬服です。
    また楽しく拝見させていただきます。

返事を書く